Cisco Airnet3702i Standalone with multiple SSID’s

Not sure if its just the version of software on my AP’s but im not able to get them fully working through cli. im able to get the config into place, then i have to go into the gui and go into services/vlans and delete the vlans then rebuild them using the gui.

on the AP I’m using vlan 20 and 40:

hostname home-office
username Cisco password Cisco123!
enable secret Cisco123!
no ip domain lookup
ip domain name home.com

dot11 vlan-name Inside_vlan vlan 20
dot11 vlan-name guestwifi vlan 40

dot11 ssid Home-secure
vlan 20
authentication open
authentication key-management wpa version 2
mbssid guest-mode
wpa-psk ascii  <wifi-password>

dot11 ssid Guest
vlan 40
authentication open
authentication key-management wpa version 2
mbssid guest-mode
wpa-psk ascii <wifi-password>
no ids mfp client

bridge irb

interface Dot11Radio0
encryption vlan 20 mode ciphers aes-ccm tkip
encryption vlan 40 mode ciphers aes-ccm tkip
ssid Home-secure
ssid Guest
mbssid
channel 2437

interface Dot11Radio0.20
encapsulation dot1Q 20 native
bridge-group 1
exit

interface Dot11Radio0.40
encapsulation dot1Q 40
bridge-group 40
exit

interface Dot11Radio1
encryption vlan 20 mode ciphers aes-ccm tkip
encryption vlan 40 mode ciphers aes-ccm tkip
ssid Home-secure
ssid Guest
mbssid
channel dfs
exit

interface Dot11Radio1.20
encapsulation dot1Q 20 native
bridge-group 1
exit

interface Dot11Radio1.40
encapsulation dot1Q 40
bridge-group 40
encryption vlan 20 mode ciphers aes-ccm tkip
encryption vlan 40 mode ciphers aes-ccm tkip
exit

interface Dot11Radio2.20
encapsulation dot1Q 20 native
bridge-group 1
exit

interface Dot11Radio2.40
encapsulation dot1Q 40
bridge-group 40
exit

interface GigabitEthernet0.20
encapsulation dot1Q 20 native
bridge-group 1
exit

interface GigabitEthernet0.40
encapsulation dot1Q 40
bridge-group 40
exit

interface BVI1
ip address 10.20.20.6 255.255.255.0
no shut

ip http server
no ip http secure-server

bridge 1 route ip

line vty 0 4
login local
transport input ssh

 

*********************************

On the switch:

interface GigabitEthernet1/0/24
description AP in upstairs hallway
switchport trunk allowed vlan 20,40
switchport trunk encapsulation dot1q
switchport trunk native vlan 20
switchport mode trunk

Was this article helpful?

Related Articles

Leave A Comment?

You must be logged in to post a comment.