Cisco – Basic Router configuration

Router>enable
Router#config t
Router(config)#hostname Cisco
Router(config)#enable password cisco123
Router(config)#enable secret Cisco123
Router(config)#line console 0
Router(config-line)#logging synchronous
Router(config-line)#password Cisco123
Router(config-line)#exec-timeout 0 0
Router(config-line)#login
Router(config)#line vty 0 4
Router(config-line)#password Cisco123
Router(config-line)#login
Router(config)#line aux 0
Router(config-line)#password Cisco123
Router(config-line)#login
Router(config)#service password-encryption
Router(config)#enable password Cisco123
Router(config)#line console 0
Router(config-line)#password Cisco123
Router(config-line)#exit
Router(config)#exit
Router#copy run start or wr mem
#show ip interface brief

************Configuring a Serial Interface
Router(config)#interface s0/0/0
Router(config-if)#description Link to ISP
Router(config-if)#ip address 192.168.10.1 255.255.255.0
Router(config-if)#clock rate 56000
Router(config-if)#no shutdown

************Configuring a Fast Ethernet Interface
Router(config)#interface fastethernet 0/0
Router(config-if)#description Accounting LAN
Router(config-if)#ip address 192.168.20.1 255.255.255.0
Router(config-if)#no shutdown

************Creating a Message-of-the-Day Banner
Router(config)#banner motd # Building Power will be interrupted next Tuesday evening from 8 – 10 PM.

************Creating a Login Banner
Router(config)#banner login # Authorized Personnel Only!

************Setting the Clock Time Zone
Router(config)#clock timezone EST –5

************Assigning a Local Host Name to an IP Address
Router(config)#ip host london 172.16.1.3
Router#ping london or Router#ping 172.16.1.3

************The no ip domain-lookup Command
Router(config)#no ip domain-lookup

************show Commands
Router#show interfaces
Router#show interface serial 0/0/0
Router#show ip interface brief
Router#show controllers serial 0/0/0
Router#show clock
Router#show hosts
Router#show users
Router#show history
Router#show flash
Router#show version
Router#show arp
Router#show protocols
Router#show startup-config
Router#show running-config

Router(config)#do show running-config
************Configuring a Static Route on a Router
Router(config)#ip route 172.16.20.0 255.255.255.0 172.16.10.2
172.16.20.0 = destination network
255.255.255.0 = subnet mask
172.16.10.2 = next-hop address

Router(config)#ip route 172.16.20.0 255.255.255.0 serial 0/0/0
172.16.20.0 = destination network
255.255.255.0 = subnet mask
Serial 0/0/0 = exit interface
************Configuring a Default Route on a Router
Router(config)#ip route 0.0.0.0 0.0.0.0 172.16.10.2
Router(config)#ip route 0.0.0.0 0.0.0.0 serial 0/0/0
Send all packets destined for networks not in my routing table to …

Router#show ip route         (Verify route)
************Configuring a Static Route on a Router
Router(config)#ip route 172.16.20.0 255.255.255.0 172.16.10.2
172.16.20.0 = destination network
255.255.255.0 = subnet mask
172.16.10.2 = next-hop address

Router(config)#ip route 172.16.20.0 255.255.255.0 serial 0/0/0
172.16.20.0 = destination network
255.255.255.0 = subnet mask
Serial 0/0/0 = exit interface
************Configuring a Default Route on a Router
Router(config)#ip route 0.0.0.0 0.0.0.0 172.16.10.2
Router(config)#ip route 0.0.0.0 0.0.0.0 serial 0/0/0
Send all packets destined for networks not in my routing table to …

Router#show ip route        (used to Verify route)
************RIP Routing
Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#network 172.16.0.0
Router(config-router)#no auto-summary
Router(config-router)#exit
Router(config)#exit
Router# copy run start

************Troubleshooting RIP Issues
Router#debug ip rip
Router#show ip rip database
************Configuring Enhanced Interior Gateway Routing Protocol (EIGRP)
Router(config)#interface serial 0/0
Router(config-if)#ip address 172.16.20.1 255.255.255.0
Router(config-if)#ip authentication mode eigrp 100 md5
Router(config-if)#ip authentication key-chain eigrp 100 Cisco123(nameofkeychain)
Router(config-if)#no shutdown
Router(config-if)#interface fastethernet 0/1
Router(config-if)#ip address 172.16.10.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#router eigrp 100
Router(config-router)#no auto-summary
Router(config-router)#eigrp log-neighbor-changes
Router(config-router)#network 172.16.0.0
Router(config-router)#key chain Cisco123
Router(config-keychain)#key 1
Router(config-keychain-key)#keystring Cisco123
Router(config-keychain-key)#acceptlifetime 06:30:00 Apr 19 2007 infinite
Router(config-keychain-key)#sendlifetime 06:30:00 Apr 19 2007 09:45:00 Apr 19 2007
Router(config-keychain-key)#exit
Router(config)#exit
Router#copy run start
************Verifying EIGRP
Router#show ip eigrp neighbors
Router#show ip eigrp neighbors detail
Router#show ip eigrp interfaces
Router#show ip eigrp interfaces serial 0/0
Router#show ip eigrp interfaces 100
Router#show ip eigrp topology
Router#show ip eigrp traffic
Router#show ip route eigrp
************Troubleshooting EIGRP
Router#debug eigrp fsm
Router#debug eigrp packet
Router#debug eigrp neighbor
Router#debug ip eigrp neighbor
Router#debug ip eigrp notifications

************Configuring OSPF
Router(config)#router ospf 123
Router(config-router)#network 172.16.10.0 0.0.0.255 area 0
Router(config-router)#network 172.16.20.0 0.0.0.255 area 0
Router(config-router)#<ctrl> z
Router# wr mem
************Verifying OSPF Configuration
Router#show ip protocol
Router#show ip route
Router#show ip ospf
Router#show ip ospf interface
Router#show ip ospf interface fastethernet 0/0
Router#show ip ospf border-routers
Router#show ip ospf neighbor
Router#show ip ospf neighbor detail
Router#show ip ospf database
Router#show ip ospf database nssa-external
************Troubleshooting OSPF
Router#clear ip route *
Router#clear ip route a.b.c.d
Router#clear ip opsf counters
Router#clear ip ospf process
Router#debug ip ospf events
Router#debug ip ospf adjacency
Router#debug ip ospf packets

Was this article helpful?

Related Articles

Leave A Comment?

You must be logged in to post a comment.